<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
		<script type="text/javascript">
				!function(){var n,o,i,e="renderMode=ie11";n=window.navigator.userAgent,o=n.indexOf("MSIE "),i=n.indexOf("Trident/"),(o>0||i>0)&&-1===window.location.href.indexOf(e)&&(window.location=window.location.href+("?"===document.location.search[0]?"&":"?")+e)}();
	</script>
			<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge" /><script type="text/javascript">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</script>
	<meta name="viewport" content="width=device-width">
	<meta name="viewport" content="initial-scale=1.0,width=device-width,user-scalable=no,minimum-scale=1.0,maximum-scale=1.0">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://techcrunch.com/xmlrpc.php">
		<script type="application/javascript">
		!function(){var n="//"+window.location.hostname+"/wp-json/tc/v1/users/check_login";fetch(n,{method:"POST",headers:{"Content-Type":"application/json; charset=utf-8"},credentials:"include"}).then(function(n){window.tc_profile={resp:n}})}();
	</script>
	<title>Instagram wasn&#8217;t removing photos and direct messages from its servers &#8211; TechCrunch</title>
<link rel='dns-prefetch' href='//s.yimg.com' />
<link rel='dns-prefetch' href='//consent.cmp.oath.com' />
<link rel='dns-prefetch' href='//use.typekit.net' />
<link rel='dns-prefetch' href='//cdn.vidible.tv' />
<link rel='dns-prefetch' href='//plugin.mediavoice.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="TechCrunch &raquo; Feed" href="https://techcrunch.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="TechCrunch &raquo; Comments Feed" href="https://techcrunch.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="TechCrunch &raquo; Instagram wasn&#8217;t removing photos and direct messages from its servers Comments Feed" href="https://techcrunch.com/2020/08/13/instagram-delete-photos-messages-servers/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/techcrunch.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://techcrunch.com/_static/??/wp-includes/css/dist/block-library/style.min.css,/wp-content/plugins/wp-parsely/wp-parsely.css,/wp-content/themes/techcrunch-2017/build/ec/css/main.css?m=1597173174' type='text/css' media='all' />
		<meta name="oath:guce:product-eu" content="false" />
		<meta name="oath:guce:consent-host" content="guce.techcrunch.com" />
		<meta name="oath:guce:inline-consent" content="true"/>
		<script async src="//s.yimg.com/oa/guce.js?tc_ver=200813"></script>
		<script async src="//s.yimg.com/oa/consent.js?tc_ver=200813"></script>
<script type='text/javascript' src='https://techcrunch.com/wp-includes/js/jquery/jquery.js?m=1597173175g'></script>
<script src='https://s.yimg.com/ss/rapid3.js?ver=20200813' id='tc-rapid-analytics-js'></script>
<script src='https://consent.cmp.oath.com/cmp.js?ver=20200813' id='tc-gdpr-cmp-js'></script>
<script src='https://s.yimg.com/pv/static/assistjs/desktop-v1.0.70.js?ver=20200813' id='tc-yahoo-assist-js'></script>
<script src='//cdn.vidible.tv/prod/player/js/latest/vidible-min.js?ver=20200813' id='tc-vidible-js-js'></script>
<script src='//plugin.mediavoice.com/mediaconductor/mc.js?ver=20200813' id='tc-mediavoice-mc-js'></script>
<link rel="https://api.w.org/" href="https://techcrunch.com/wp-json/" /><link rel="alternate" type="application/json" href="https://techcrunch.com/wp-json/wp/v2/posts/2031308" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://techcrunch.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://techcrunch.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5" />
<link rel="canonical" href="https://techcrunch.com/2020/08/13/instagram-delete-photos-messages-servers/" />
<link rel='shortlink' href='https://techcrunch.com/?p=2031308' />
<link rel="alternate" type="application/json+oembed" href="https://techcrunch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftechcrunch.com%2F2020%2F08%2F13%2Finstagram-delete-photos-messages-servers%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://techcrunch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftechcrunch.com%2F2020%2F08%2F13%2Finstagram-delete-photos-messages-servers%2F&#038;format=xml" />


<!-- BEGIN Sailthru Horizon Meta Information -->
<meta name="sailthru.date" content="2020-08-13 11:53:38" />
<meta name="sailthru.title" content="Instagram wasn&#8217;t removing photos and direct messages from its servers" />
<meta name="sailthru.tags" content="computing, Instagram, mobile software, operating systems, social media, Software, Twitter" />
<meta name="sailthru.description" content="A security researcher was awarded a $6,000 bug bounty payout after he found Instagram retained photos and private direct messages on its servers long after he deleted them. Independent security researcher Saugat Pokharel found that when he downloaded his data from Instagram, a feature it launched in 2018 to comply with new European data rules, [&hellip;]" />
<meta name="sailthru.image.full" content="https://techcrunch.com/wp-content/uploads/2020/08/GettyImages-1206514283.jpg" />
<meta name="sailthru.image.thumb" content="https://techcrunch.com/wp-content/uploads/2020/08/GettyImages-1206514283.jpg?w=50" />
<!-- END Sailthru Horizon Meta Information -->


<!-- BEGIN wp-parsely Plugin Version 2.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="2.0"/>
			<script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/techcrunch.com\/2020\/08\/13\/instagram-delete-photos-messages-servers\/"},"headline":"Instagram wasn&#039;t removing photos and direct messages from its servers","url":"http:\/\/techcrunch.com\/2020\/08\/13\/instagram-delete-photos-messages-servers\/","thumbnailUrl":"https:\/\/techcrunch.com\/wp-content\/uploads\/2020\/08\/GettyImages-1206514283.jpg?w=150","image":{"@type":"ImageObject","url":"https:\/\/techcrunch.com\/wp-content\/uploads\/2020\/08\/GettyImages-1206514283.jpg?w=150"},"dateCreated":"2020-08-13T18:53:38Z","datePublished":"2020-08-13T18:53:38Z","dateModified":"2020-08-13T18:53:38Z","articleSection":"post","author":[{"@type":"Person","name":"Zack Whittaker"}],"creator":["Zack Whittaker"],"keywords":["@post-id:2031308","apps","privacy","security","social","computing","instagram","mobile software","operating systems","social media","software","twitter"],"publisher":{"@type":"Organization","name":"TechCrunch","logo":{"@type":"imageObject","url":"https:\/\/techcrunch.com\/wp-content\/themes\/techcrunch-2017\/images\/logo-json-ld.png","width":"600","height":"60"}}}
		</script>

			<!-- END wp-parsely Plugin Version 2.0 -->
<style type='text/css'>img#wpstats{display:none}</style>		<script defer src="https://s.yimg.com/uc/sf/latest/js/safe.min.js?ver=c86a1bcc8ffb1efa0e50ec766f16d9ae"></script>
		<script defer src="https://techcrunch.com/wp-content/themes/techcrunch-2017/features/analytics/nps/load-in.js"></script>
		<meta property="fb:app_id" content="187288694643718" />
		<meta property="fb:pages" content="8062627951" />
		<meta property="fb:admins" content="8803025,726995222,1550970059,1661021707,1178144075,643979435,4700188" />
		<meta property="article:publisher" content="https://www.facebook.com/techcrunch" />
		<meta property="og:site_name" content="TechCrunch" />
		<meta property="og:site" content="social.techcrunch.com" />
		<meta property="og:title" content="Instagram wasn&#8217;t removing photos and direct messages from its servers &#8211; TechCrunch" />
		<meta property="og:description" content="Photos and private messages could still be downloaded, long after users thought they were deleted." />
		<meta property="og:image" content="https://techcrunch.com/wp-content/uploads/2020/08/GettyImages-1206514283.jpg?w=600" />
		<meta property="og:url" content="https://social.techcrunch.com/2020/08/13/instagram-delete-photos-messages-servers/" />
		<meta property="og:type" content="article" />
		<meta name="description" content="Photos and private messages could still be downloaded, long after users thought they were deleted." />
		<meta name="title" content="Instagram wasn&#8217;t removing photos and direct messages from its servers &#8211; TechCrunch" />
		<meta name="twitter:card" content="summary_large_image" />
		<meta name="twitter:site" content="@techcrunch" />
		<meta name="twitter:title" content="Instagram wasn&#8217;t removing photos and direct messages from its servers" />
		<meta name="twitter:description" content="Photos and private messages could still be downloaded, long after users thought they were deleted." />
		<meta name="twitter:creator" content="@zackwhittaker" />
		<meta name="twitter:image" content="https://techcrunch.com/wp-content/uploads/2020/08/GettyImages-1206514283.jpg?w=600" />
<script type="text/javascript">var ajaxurl = "https://techcrunch.com/wp-admin/admin-ajax.php"</script><link rel="amphtml" href="https://techcrunch.com/2020/08/13/instagram-delete-photos-messages-servers/amp/"><link rel="icon" href="https://techcrunch.com/wp-content/uploads/2015/02/cropped-cropped-favicon-gradient.png?w=32" sizes="32x32" />
<link rel="icon" href="https://techcrunch.com/wp-content/uploads/2015/02/cropped-cropped-favicon-gradient.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://techcrunch.com/wp-content/uploads/2015/02/cropped-cropped-favicon-gradient.png?w=180" />
<meta name="msapplication-TileImage" content="https://techcrunch.com/wp-content/uploads/2015/02/cropped-cropped-favicon-gradient.png?w=270" />
<script type='text/javascript' src='https://s.aolcdn.com/ads/adsWrapper.js?tc_ver=20200813'></script>
<script type='text/javascript'>
	try{adsEnableSandbox();}catch(e){}
</script>
	</head>
<body class="">

<div id="root">
	<div><!-- duplicate React-root div for styling -->
	<div class="content">
		<article class="article-container article--post ">
			<header class="article__header ">
	<div class="article__title-wrapper">
						<h1 class="article__title">Instagram wasn&#8217;t removing photos and direct messages from its servers</h1>
		</div>

			<div class="article__byline-wrapper">
			
<div class="article__byline">
			<a href="https://techcrunch.com/author/zack-whittaker/">
			Zack Whittaker		</a>
		<span class="article__byline__meta">
							<a href="https://twitter.com/zackwhittaker">@zackwhittaker</a>
				<span class="text--green"> / </span>
						8 hours		</span>
	</div>
		</div>
	
			<div class="article__featured-image-wrapper breakout">
			<img src="https://techcrunch.com/wp-content/uploads/2020/08/GettyImages-1206514283.jpg?w=600" class="article__featured-image" />
		</div>
	</header>

			<div class="article-content">
				<p id="speakable-summary">A security researcher was awarded a $6,000 bug bounty payout after he found <a class="crunchbase-link" href="https://crunchbase.com/organization/instagram" target="_blank" data-type="organization" data-entity="instagram">Instagram <span class="crunchbase-tooltip-indicator"></span></a> retained photos and private direct messages on its servers long after he deleted them.</p>
<p>Independent security researcher Saugat Pokharel found that when he downloaded his data from Instagram, a feature it <a href="https://techcrunch.com/2018/04/24/instagram-export/">launched in 2018</a> to comply with new European data rules, his downloaded data contained photos and private messages with other users that he had previously deleted.</p>
<p>It&#8217;s not uncommon for companies to store freshly deleted data for a time until it can be properly scrubbed from its networks, systems and caches. Instagram said it takes about 90 days for deleted data to be fully removed from its systems.</p>
<p>But Pokharel found that his ostensibly deleted data from more than a year ago was still stored on Instagram&#8217;s servers, and could be downloaded using the company&#8217;s data download tool.</p>
<p>&#8220;Instagram didn&#8217;t delete my data even when I deleted them from my end,&#8221; he told TechCrunch.</p>
<p>Pokharel reported the bug in October 2019 through Instagram&#8217;s bug bounty program. The bug was fixed earlier this month, he said.</p>
<p>A spokesperson for Instagram told TechCrunch: &#8220;The researcher reported an issue where someone&#8217;s deleted Instagram images and messages would be included in a copy of their information if they used our Download Your Information tool on Instagram. We&#8217;ve fixed the issue and have seen no evidence of abuse. We thank the researcher for reporting this issue to us.&#8221;</p>
<p>It&#8217;s <a href="https://techcrunch.com/2019/02/15/twitter-direct-messages/">a near-identical issue</a> that Twitter fixed last year, in which users could access long-deleted direct messages — including messages sent to and from suspended and deactivated accounts — using its own data download tool.</p>
<div class="embed breakout">
<blockquote class="wp-embedded-content" data-secret="PkIRicUMOI"><p><a href="https://techcrunch.com/2019/02/15/twitter-direct-messages/">Even years later, Twitter doesn&#8217;t delete your direct messages</a></p></blockquote>
<p><iframe class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" title="&#8220;Even years later, Twitter doesn&#8217;t delete your direct messages&#8221; &#8212; TechCrunch" src="https://techcrunch.com/2019/02/15/twitter-direct-messages/embed/#?secret=PkIRicUMOI" data-secret="PkIRicUMOI" width="800" height="450" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></div>
			</div>

			<footer class="article-footer">
									<input title="Article Shortlink" class="shortlink" readOnly type="text" value="" />
								</footer>
		</article>
	</div>
		</div><!-- end React-root duplication div -->
</div><!--end #root-->

		<noscript style="display:none;">
			<img height="1" width="1" alt="" src="https://www.facebook.com/tr?id=1447508128842484&ev=PageView&noscript=1"/>
		</noscript>
	<script type="text/javascript">
		// Configure the PARSELY window global to disable auto-tracking.
		// Must load before the Parse.ly script itself.
		window.PARSELY = {
			autotrack: false,
			onload:    this.onload,
		};
	</script>
	<script id="parsely-cfg" data-parsely-site="techcrunch.com" src="//d1z2jf7jlzjs58.cloudfront.net/keys/techcrunch.com/p.js?tc_ver=20200813"></script>
		<script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'428726','qstrings': { 'et': 'custom','ea': 'page view','product_id': window.location.pathname,'site': 'techcrunch' },}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");
	</script>
		<!-- JSON-LD -->
	<script type="application/ld+json">
		{"@context":"http:\/\/schema.org","publisher":{"@type":"Organization","name":"TechCrunch","logo":{"@type":"imageObject","url":"https:\/\/techcrunch.com\/wp-content\/themes\/techcrunch-2017\/images\/logo-json-ld.png","width":"600","height":"60"}},"@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/techcrunch.com\/2020\/08\/13\/instagram-delete-photos-messages-servers\/"},"headline":"Instagram wasn&#8217;t removing photos and direct messages from its servers","image":{"@type":"ImageObject","url":"https:\/\/techcrunch.com\/wp-content\/uploads\/2020\/08\/GettyImages-1206514283.jpg?w=680","width":680,"height":453},"datePublished":"2020-08-13T18:53:38+00:00","dateModified":"2020-08-13T20:01:43+00:00","author":[{"@type":"Person","name":"Zack Whittaker"}],"description":"A security researcher was awarded a $6,000 bug bounty payout after he found Instagram retained photos and private direct messages on its servers long after he deleted them. Independent security researcher Saugat Pokharel found that when he downloaded his data from Instagram, a feature it launched in 2018 to comply with new European data rules, [&hellip;]","speakable":{"@type":"SpeakableSpecification","cssSelector":[".alpha","#speakable-summary"]}}	</script>
	<!-- End JSON-LD -->
	<script src='https://use.typekit.net/svv7knm.js?ver=20200813' id='tc-typekit-font-js'></script>
<script id='tc-typekit-font-js-after'>
try{Typekit.load({ async: true });}catch(e){}
</script>
<script id='tc-app-js-extra'>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</script>
<script type='text/javascript' src='https://techcrunch.com/_static/??-eJyFjEkOwjAMRS9Ea1KGwgL1LK1jFIfEQY0tro93LFn9Se/D5z1gEyVR0ESVOihhwt0E0zAdwwybcYlACLlDXVnG3A/gGAsWiw5475HqRnGsv/3P7ZNWtd0HUy6s7A5be7n6wVIf4XKfp+v5Fk75C1A0On4='></script>
<script type='text/javascript' src='https://stats.wp.com/e-202033.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8.1',blog:'136296444',post:'2031308',tz:'-7',srv:'techcrunch.com'} ]);
	_stq.push([ 'clickTrackerInit', '136296444', '2031308' ]);
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"4750574831","applicationID":"71001471","transactionName":"NlRbNkYEWERTVkVcXA8eeAFADFlZHUZYW1QNVA==","queueTime":0,"applicationTime":395,"atts":"GhNMQA4eSxsQVBMPSBxM","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
