<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
		<script type="text/javascript">
				!function(){var n,o,i,e="renderMode=ie11";n=window.navigator.userAgent,o=n.indexOf("MSIE "),i=n.indexOf("Trident/"),(o>0||i>0)&&-1===window.location.href.indexOf(e)&&(window.location=window.location.href+("?"===document.location.search[0]?"&":"?")+e)}();
	</script>
			<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
	<meta name="viewport" content="width=device-width">
	<meta name="viewport" content="initial-scale=1.0,width=device-width,user-scalable=no,minimum-scale=1.0,maximum-scale=1.0">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://techcrunch.com/xmlrpc.php">
		<script type="application/javascript">
		if ( ! window.isSSR ) {
			!function(){var e,t,n,i,r={passive:!0,capture:!0},a=new Date,o=function(){i=[],t=-1,e=null,f(addEventListener);},c=function(i,r){e||(e=r,t=i,n=new Date,f(removeEventListener),u());},u=function(){if(t>=0&&t<n-a){var r={entryType:"first-input",name:e.type,target:e.target,cancelable:e.cancelable,startTime:e.timeStamp,processingStart:e.timeStamp+t};i.forEach((function(e){e(r);})),i=[];}},s=function(e){if(e.cancelable){var t=(e.timeStamp>1e12?new Date:performance.now())-e.timeStamp;"pointerdown"==e.type?function(e,t){var n=function(){c(e,t),a();},i=function(){a();},a=function(){removeEventListener("pointerup",n,r),removeEventListener("pointercancel",i,r);};addEventListener("pointerup",n,r),addEventListener("pointercancel",i,r);}(t,e):c(t,e);}},f=function(e){["mousedown","keydown","touchstart","pointerdown"].forEach((function(t){return e(t,s,r)}));},p="hidden"===document.visibilityState?0:1/0;addEventListener("visibilitychange",(function e(t){"hidden"===document.visibilityState&&(p=t.timeStamp,removeEventListener("visibilitychange",e,!0));}),!0);o(),self.webVitals={firstInputPolyfill:function(e){i.push(e),u();},resetFirstInputPolyfill:o,get firstHiddenTime(){return p}};}();
		}
	</script>
	<script defer async src="https://s.yimg.com/aaq/pv/perf-vitals_2.0.0.js"></script>	<script type="application/javascript">
		!function(){var n="//"+window.location.hostname+"/wp-json/tc/v1/users/check_login";fetch(n,{method:"POST",headers:{"Content-Type":"application/json; charset=utf-8"},credentials:"include"}).then(function(n){window.tc_profile={resp:n}})}();
	</script>
	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v19.1 (Yoast SEO v19.5.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Pinecone vector database can now handle hybrid keyword-semantic search &bull; TechCrunch</title>
	<meta name="description" content="Pinecone, a vector database for machine learning, announced the ability to combine keywords with semantic questions in a hybrid search today." />
	<link rel="canonical" href="https://techcrunch.com/2022/10/31/pinecone-vector-database-can-now-handle-hybrid-keyword-semantic-search/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Pinecone vector database can now handle hybrid keyword-semantic search" />
	<meta property="og:description" content="Pinecone, a vector database for machine learning, announced the ability to combine keywords with semantic questions in a hybrid search today." />
	<meta property="og:url" content="https://techcrunch.com/2022/10/31/pinecone-vector-database-can-now-handle-hybrid-keyword-semantic-search/" />
	<meta property="og:site_name" content="TechCrunch" />
	<meta property="article:publisher" content="https://www.facebook.com/techcrunch" />
	<meta property="article:published_time" content="2022-10-31T14:01:05+00:00" />
	<meta property="article:modified_time" content="2022-10-31T16:28:39+00:00" />
	<meta property="og:image" content="https://techcrunch.com/wp-content/uploads/2022/10/GettyImages-1318395692.jpg?resize=1200,800" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="800" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Ron Miller" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@TechCrunch" />
	<meta name="twitter:site" content="@TechCrunch" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Ron Miller" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//cdn.parsely.com' />
<link rel='dns-prefetch' href='//s.yimg.com' />
<link rel='dns-prefetch' href='//consent.cmp.oath.com' />
<link rel='dns-prefetch' href='//use.typekit.net' />
<link rel='dns-prefetch' href='//cdn.vidible.tv' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='preconnect' href='//googleads.g.doubleclick.net' />
<link rel='preconnect' href='//pagead2.googlesyndication.com' />
<link rel='preconnect' href='//use.typekit.net' />
<link rel='preconnect' href='//jac.yahoosandbox.com' />
<link rel='preconnect' href='//s.yimg.com' />
<link rel='preconnect' href='//api.parsely.com' />
<link rel='preconnect' href='//sp.analytics.yahoo.com' />
<link rel='preconnect' href='//connect.facebook.net' />
<link rel="alternate" type="application/rss+xml" title="TechCrunch &raquo; Feed" href="https://techcrunch.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="TechCrunch &raquo; Comments Feed" href="https://techcrunch.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="TechCrunch &raquo; Pinecone vector database can now handle hybrid keyword-semantic search Comments Feed" href="https://techcrunch.com/2022/10/31/pinecone-vector-database-can-now-handle-hybrid-keyword-semantic-search/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/techcrunch.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://techcrunch.com/_static/??-eJyNj9EOwjAIRX/IDueS+WT8lo6SidKuKSymf++cWbK9+XiBAxx4Z8cJZQ6kgKoQWA0GmfDlhIfiSwW1KtRETs0ycII98VSIFNiTUKRkh5DFVypOaPRY/8OX3j4fIJySrSdml2UeOSko+YIPIPFqjLnQ9v9XpCxlo+DypKbuZ7Sa6Lb2Hm9t3/fXtuvOlw83h2L3' type='text/css' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://techcrunch.com/wp-content/themes/techcrunch-2017/build/ec/css/main.css?m=1666625080g' type='text/css' media='all' />
		<meta name="oath:guce:product-eu" content="false" />
		<meta name="oath:guce:consent-host" content="guce.techcrunch.com" />
		<meta name="oath:guce:inline-consent" content="true"/>
		<script async src="//s.yimg.com/oa/consent.js?tc_ver=221031"></script>
<script src='https://s.yimg.com/ss/rapid3.js?ver=20221031' id='tc-rapid-analytics-js'></script>
<script src='https://consent.cmp.oath.com/cmpStub.min.js?ver=20221031' id='tc-gdpr-cmp-stub-js'></script>
<script src='https://s.yimg.com/cx/acookie/acookie.js?ver=20221031' id='tc-gdpr-acookie-js'></script>
<script src='https://s.yimg.com/pv/static/assistjs/desktop-v1.0.70.js?ver=20221031' id='tc-yahoo-assist-js'></script>
<script src='//cdn.vidible.tv/prod/player/js/latest/vidible-min.js?ver=20221031' id='tc-vidible-js-js'></script>
<link rel="https://api.w.org/" href="https://techcrunch.com/wp-json/" /><link rel="alternate" type="application/json" href="https://techcrunch.com/wp-json/wp/v2/posts/2433766" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://techcrunch.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://techcrunch.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.3" />
<link rel='shortlink' href='https://techcrunch.com/?p=2433766' />
<link rel="alternate" type="application/json+oembed" href="https://techcrunch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftechcrunch.com%2F2022%2F10%2F31%2Fpinecone-vector-database-can-now-handle-hybrid-keyword-semantic-search%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://techcrunch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftechcrunch.com%2F2022%2F10%2F31%2Fpinecone-vector-database-can-now-handle-hybrid-keyword-semantic-search%2F&#038;format=xml" />


<!-- BEGIN Sailthru Horizon Meta Information -->
<meta name="sailthru.date" content="2022-10-31 07:01:05" />
<meta name="sailthru.title" content="Pinecone vector database can now handle hybrid keyword-semantic search" />
<meta name="sailthru.tags" content="keyword search, machine learning, Pinecone, semantic search, vector database" />
<meta name="sailthru.author" content="Ron Miller" />
<meta name="sailthru.description" content="When Pinecone announced a vector database at the beginning of last year, it was building something that was specifically designed for machine learning and aimed at data scientists. The idea was that you could query this data in a format that machines understand, making it much faster. Originally this involved semantic searches where users could [&hellip;]" />
<meta name="sailthru.image.full" content="https://techcrunch.com/wp-content/uploads/2022/10/GettyImages-1318395692.jpg" />
<meta name="sailthru.image.thumb" content="https://techcrunch.com/wp-content/uploads/2022/10/GettyImages-1318395692.jpg?w=50" />
<!-- END Sailthru Horizon Meta Information -->

<style>img#wpstats{display:none}</style>
	<meta name="parsely-title" content="Pinecone vector database can now handle hybrid keyword-semantic search" />
<meta name="parsely-link" content="https://techcrunch.com/2022/10/31/pinecone-vector-database-can-now-handle-hybrid-keyword-semantic-search/" />
<meta name="parsely-type" content="post" />
<meta name="parsely-pub-date" content="2022-10-31T14:01:05+00:00" />
<meta name="parsely-image-url" content="https://techcrunch.com/wp-content/uploads/2022/10/GettyImages-1318395692.jpg?w=680" />
<meta name="parsely-author" content="Ron Miller" />
<meta name="parsely-section" content="Enterprise" />
<meta name="parsely-tags" content="@post-id:2433766,startups,keyword search,machine learning,pinecone,semantic search,vector database" />
<meta name="parsely-metadata" content="{&quot;@type&quot;:&quot;NewsArticle&quot;,&quot;mainEntityOfPage&quot;:{&quot;@type&quot;:&quot;WebPage&quot;},&quot;dateModified&quot;:&quot;2022-10-31T16:28:39+00:00&quot;,&quot;description&quot;:&quot;When Pinecone announced a vector database at the beginning of last year, it was building something that was specifically designed for machine learning and aimed at data scientists. The idea was that you could query this data in a format that machines understand, making it much faster. Originally this involved semantic searches where users could [&hellip;]&quot;,&quot;speakable&quot;:{&quot;@type&quot;:&quot;SpeakableSpecification&quot;,&quot;cssSelector&quot;:[&quot;.alpha&quot;,&quot;#speakable-summary&quot;]},&quot;publisher&quot;:{&quot;@type&quot;:&quot;Organization&quot;,&quot;name&quot;:&quot;TechCrunch&quot;,&quot;logo&quot;:{&quot;@type&quot;:&quot;imageObject&quot;,&quot;url&quot;:&quot;https:\/\/techcrunch.com\/wp-content\/themes\/techcrunch-2017\/images\/logo-json-ld.png&quot;,&quot;width&quot;:&quot;600&quot;,&quot;height&quot;:&quot;60&quot;}}}" />	<script type="text/javascript">
		function e(e){var t=!(arguments.length>1&&void 0!==arguments[1])||arguments[1],c=document.createElement("script");c.src=e,t?c.type="module":(c.async=!0,c.type="text/javascript",c.setAttribute("nomodule",""));var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(c,n)}function t(t,c,n){var a,o,r;null!==(a=t.marfeel)&&void 0!==a||(t.marfeel={}),null!==(o=(r=t.marfeel).cmd)&&void 0!==o||(r.cmd=[]),t.marfeel.config=n,t.marfeel.config.accountId=c;var i="https://sdk.mrf.io/statics";e("".concat(i,"/marfeel-sdk.js?id=").concat(c),!0),e("".concat(i,"/marfeel-sdk.es5.js?id=").concat(c),!1)}!function(e,c){var n=arguments.length>2&&void 0!==arguments[2]?arguments[2]:{};t(e,c,n)}(window,1860,{} /*config*/);
	</script>
	<meta name="cXenseParse:articleid" content="2433766" /><meta name="cXenseParse:title" content="Pinecone vector database can now handle hybrid keyword-semantic search" /><meta name="cXenseParse:postType" content="post" /><meta name="cXenseParse:keywords" content="enterprise,startups,keyword search,machine learning,pinecone,semantic search,vector database" /><meta name="cXenseParse:news_keywords" content="enterprise,startups,keyword search,machine learning,pinecone,semantic search,vector database" /><meta property="cXenseParse:author" data-separator="," content="Ron Miller" /><meta name="cXenseParse:recs:publishtime" content="2022-10-31T14:01:05Z" /><meta name="cXenseParse:modified_time" content="2022-10-31T16:28:39Z" /><meta name="cXenseParse:pageClass" content="article" /><meta name="cXenseParse:description" content="When Pinecone announced a vector database at the beginning of last year, it was building something that was specifically designed for machine learning and aimed at data scientists. The idea was that you could query this data in a format that machines understand, making it much faster. Originally this involved semantic searches where users could [&hellip;]" /><meta name="cXenseParse:url" content="https://techcrunch.com/2022/10/31/pinecone-vector-database-can-now-handle-hybrid-keyword-semantic-search/" /><meta name="cXenseParse:image" content="https://techcrunch.com/wp-content/uploads/2022/10/GettyImages-1318395692.jpg?w=600" />		<meta property="fb:app_id" content="187288694643718" />
		<meta property="fb:pages" content="8062627951" />
		<meta property="fb:admins" content="8803025,726995222,1550970059,1661021707,1178144075,643979435,4700188" />
		<meta property="article:publisher" content="https://www.facebook.com/techcrunch" />
<script async src="https://consent.cmp.oath.com/cmp.js" type="text/javascript" id="tc-gdpr-cmp"></script>	<script data-ad-client="ca-pub-2508481855317367" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script type="text/javascript">var ajaxurl = "https://techcrunch.com/wp-admin/admin-ajax.php"</script><link rel="amphtml" href="https://techcrunch.com/2022/10/31/pinecone-vector-database-can-now-handle-hybrid-keyword-semantic-search/amp/"><link rel="icon" href="https://techcrunch.com/wp-content/uploads/2015/02/cropped-cropped-favicon-gradient.png?w=32" sizes="32x32" />
<link rel="icon" href="https://techcrunch.com/wp-content/uploads/2015/02/cropped-cropped-favicon-gradient.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://techcrunch.com/wp-content/uploads/2015/02/cropped-cropped-favicon-gradient.png?w=180" />
<meta name="msapplication-TileImage" content="https://techcrunch.com/wp-content/uploads/2015/02/cropped-cropped-favicon-gradient.png?w=270" />
	<script type="text/javascript">
		const desktopSpaceId = "1197802919";
		const mobileSpaceId = "1197802920";
		const mnPlacements = '{"amp_footer":{"alias":"93523762","sizes":["6x2"]},"amp_leaderboard":{"alias":"963912138","sizes":["6x2"]},"amp_midarticle":{"alias":"963923317","sizes":["6x2"]},"article_footer":{"alias":"963908973","sizes":"LB"},"leaderboard":{"alias":"93484988","sizes":"LB"},"midarticle1":{"alias":"963923871","sizes":["6x2"]},"midarticle2":{"alias":"963923883","sizes":["6x2"]},"mobile_footer":{"alias":"93484986","sizes":"MM"},"mobile_leaderboard":{"alias":"93484987","sizes":"MM"},"mobile_midarticle1":{"alias":"963923872","sizes":["6x2"]},"mobile_midarticle2":{"alias":"963923884","sizes":["6x2"]},"native_inriver":{"alias":"93501877","sizes":["6x2"]},"native_midarticle":{"alias":"963922183","sizes":["6x2"]},"native_mobile_footer":{"alias":"963923619","sizes":["6x2"]},"native_mobile_inriver":{"alias":"93501878","sizes":["6x2"]},"native_mobile_midarticle":{"alias":"963922184","sizes":["6x2"]},"native_rightrail1":{"alias":"963912091","sizes":["6x2"]},"native_rightrail2":{"alias":"963913330","sizes":["6x2"]},"rightrail1":{"alias":"93484989","sizes":"RR"},"rightrail2":{"alias":"963913915","sizes":"RR"},"xl_midarticle1":{"alias":"963923870","sizes":["6x2"]},"xl_midarticle2":{"alias":"963923882","sizes":["6x2"]}}';
				!function(){const userAgent=window.navigator.userAgent;window.spaceId=desktopSpaceId,(/Android|webOS|iPhone|iPod|Blackberry|Mobile|mobile/i.test(userAgent)||/(android|bb\d+|meego).+mobile|avantgo|bada\/|blackberry|blazer|compal|elaine|fennec|hiptop|iemobile|ip(hone|od)|iris|kindle|lge |maemo|midp|mmp|mobile.+firefox|netfront|opera m(ob|in)i|palm( os)?|phone|p(ixi|re)\/|plucker|pocket|psp|series(4|6)0|symbian|treo|up\.(browser|link)|vodafone|wap|windows ce|xda|xiino/i.test(userAgent)||/1207|6310|6590|3gso|4thp|50[1-6]i|770s|802s|a wa|abac|ac(er|oo|s-)|ai(ko|rn)|al(av|ca|co)|amoi|an(ex|ny|yw)|aptu|ar(ch|go)|as(te|us)|attw|au(di|-m|r |s )|avan|be(ck|ll|nq)|bi(lb|rd)|bl(ac|az)|br(e|v)w|bumb|bw-(n|u)|c55\/|capi|ccwa|cdm-|cell|chtm|cldc|cmd-|co(mp|nd)|craw|da(it|ll|ng)|dbte|dc-s|devi|dica|dmob|do(c|p)o|ds(12|-d)|el(49|ai)|em(l2|ul)|er(ic|k0)|esl8|ez([4-7]0|os|wa|ze)|fetc|fly(-|_)|g1 u|g560|gene|gf-5|g-mo|go(\.w|od)|gr(ad|un)|haie|hcit|hd-(m|p|t)|hei-|hi(pt|ta)|hp( i|ip)|hs-c|ht(c(-| |_|a|g|p|s|t)|tp)|hu(aw|tc)|i-(20|go|ma)|i230|iac( |-|\/)|ibro|idea|ig01|ikom|im1k|inno|ipaq|iris|ja(t|v)a|jbro|jemu|jigs|kddi|keji|kgt( |\/)|klon|kpt |kwc-|kyo(c|k)|le(no|xi)|lg( g|\/(k|l|u)|50|54|-[a-w])|libw|lynx|m1-w|m3ga|m50\/|ma(te|ui|xo)|mc(01|21|ca)|m-cr|me(rc|ri)|mi(o8|oa|ts)|mmef|mo(01|02|bi|de|do|t(-| |o|v)|zz)|mt(50|p1|v )|mwbp|mywa|n10[0-2]|n20[2-3]|n30(0|2)|n50(0|2|5)|n7(0(0|1)|10)|ne((c|m)-|on|tf|wf|wg|wt)|nok(6|i)|nzph|o2im|op(ti|wv)|oran|owg1|p800|pan(a|d|t)|pdxg|pg(13|-([1-8]|c))|phil|pire|pl(ay|uc)|pn-2|po(ck|rt|se)|prox|psio|pt-g|qa-a|qc(07|12|21|32|60|-[2-7]|i-)|qtek|r380|r600|raks|rim9|ro(ve|zo)|s55\/|sa(ge|ma|mm|ms|ny|va)|sc(01|h-|oo|p-)|sdk\/|se(c(-|0|1)|47|mc|nd|ri)|sgh-|shar|sie(-|m)|sk-0|sl(45|id)|sm(al|ar|b3|it|t5)|so(ft|ny)|sp(01|h-|v-|v )|sy(01|mb)|t2(18|50)|t6(00|10|18)|ta(gt|lk)|tcl-|tdg-|tel(i|m)|tim-|t-mo|to(pl|sh)|ts(70|m-|m3|m5)|tx-9|up(\.b|g1|si)|utst|v400|v750|veri|vi(rg|te)|vk(40|5[0-3]|-v)|vm40|voda|vulc|vx(52|53|60|61|70|80|81|83|85|98)|w3c(-| )|webc|whit|wi(g |nc|nw)|wmlb|wonu|x700|yas-|your|zeto|zte-/i.test(userAgent.substr(0,4)))&&(window.spaceId=mobileSpaceId),window.JAC_CONFIG={service:{adServer:{"1AS":{region:"US"}},site:{name:"TechCrunch",spaceId:window.spaceId},debug:!1,positions:JSON.parse(mnPlacements)},client:{onReady:function(){window.JAC&&(window.JAC_READY=!0,document.dispatchEvent(new CustomEvent("JACReady")),window.JAC.on("FETCH_ERROR",e=>{e.meta.positionNames.length>0&&e.meta.positionnames.forEach(e=>{document.dispatchEvent(new CustomEvent(`adEmpty-${e}`,{detail:{id:e}}))})}),window.JAC.on("FETCH_COMPLETE",e=>{let i="",t={width:0,height:0},o=0;if(e.meta.positionNames.length>0&&(i=e.meta.positionNames[0],t=e.meta.response.positions[i].content.size,o=e.meta.response.positions[i].status),null!==document.querySelector(`#tc-ad-${i}`)&&1===o){let e=t.width,o=t.height;i.includes("native")&&(t.width<10||t.height<10)&&(e=859,o=250),document.dispatchEvent(new CustomEvent(`adLoaded-${i}`,{detail:{id:i,width:e,height:o}})),window.JAC.render([i])}else document.dispatchEvent(new CustomEvent(`adEmpty-${i}`,{detail:{id:i}}))}),window.JAC.on("AD_SIZE_CHANGED",e=>{let{positionName:i,width:t,height:o}=e.meta;i.includes("native")&&(t<10||o<10)&&(t=859,o=250),document.dispatchEvent(new CustomEvent(`adLoaded-${i}`,{detail:{id:i,width:t,height:o}}))}))}}};}();
	</script>
	<script async src="https://jill.fc.yahoo.com/v1/client/js?site.name=TechCrunch"></script></head>
<body class="">

<div id="root">
	<div><!-- duplicate React-root div for styling -->
	<div class="content">
		<article class="article-container article--post ">
			<header class="article__header ">
	<div class="article__title-wrapper">
						<h1 class="article__title">Pinecone vector database can now handle hybrid keyword-semantic search</h1>
		</div>

			<div class="article__byline-wrapper">
			
<div class="article__byline">
			<a href="https://techcrunch.com/author/">
			Ron Miller		</a>
		<span class="article__byline__meta">
						10 hours		</span>
	</div>
		</div>
	
			<div class="article__featured-image-wrapper breakout">
			<img src="https://techcrunch.com/wp-content/uploads/2022/10/GettyImages-1318395692.jpg?w=600" class="article__featured-image" />
		</div>
	</header>

			<div class="article-content">
				<p id="speakable-summary">When <a href="https://www.pinecone.io/" target="_blank" rel="noopener">Pinecone</a> announced a vector database at the beginning of last year, it was building something that was specifically designed for machine learning and aimed at data scientists. The idea was that you could query this data in a format that machines understand, making it much faster.</p>
<p>Originally this involved semantic searches where users could search based on meaning instead of specific words. It turns out, however, that as people put Pinecone to work, there were use cases where specific keywords mattered, and today the company announced that it’s now possible to conduct searches combining both semantic and keyword searches, what company founder and CEO Edo Liberty calls hybrid search.</p>
<p>“We&#8217;ve conducted a lot of research on this topic and we found that, in fact, hybrid search ends up being better [in many cases]. It&#8217;s better in the sense that if you can combine both semantic search, this is the deep NLP encoding of sentences that gets the context and the meaning and so on, but you can also infuse that with specific keywords…the combination of those two ends up being significantly better,” Liberty told TechCrunch.</p>
<p>In fact he says the two complement each other well, especially in cases where industry-specific terms matter. This could be something like a doctor searching for keywords related to a specific disease. In those cases, the medical context may return better results by combining a question and some specific keywords around a given disease.</p>
<p>He says that the keywords never take precedence over the semantic question the user is asking, but they provide some extra information to help return more meaningful results.</p><div class="piano-inline-promo"></div>
<p>“You might know exactly what you&#8217;re looking for, and you might be able to provide extra oomph when you make your semantic search keyword-aware &#8212; and that actually helps a lot. So I don&#8217;t want to throw away the good parts of keyword search [by relying completely on semantic search]. I don&#8217;t want the keywords to be in the driver&#8217;s seat, but I don&#8217;t to ignore them completely either,” he said.</p>
<p>As Liberty told us at the time of the company’s <a href="https://techcrunch.com/2022/03/29/pinecone-announces-28m-series-a-for-purpose-built-database-aimed-at-data-scientists/">$28 million Series A</a> last year, search has become a big use case for the company.</p>
<p>“The predominant use of the vector databases is for search, and search in the broad sense of the word. It’s searching through documents, but you can think about search as information retrieval in general, discovery, recommendation, anomaly detection and so on,” he said at the time.</p>
<p>Pinecone launched in 2019 and has raised $38 million, <a href="https://www.crunchbase.com/organization/pinecone">per Crunchbase</a>.</p>
			</div>

			<footer class="article-footer">
									<input title="Article Shortlink" class="shortlink" readOnly type="text" value="" />
								</footer>
		</article>
	</div>
		</div><!-- end React-root duplication div -->
</div><!--end #root-->
	<script type="text/javascript">
		// Configure the PARSELY window global to disable auto-tracking.
		// Must load before the Parse.ly script itself.
		window.PARSELY = {
			autotrack: false,
			onload:    this.onload,
		};
	</script>
		<script type="application/javascript">
		if ( ! window.isSSR ) { 
			(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'428726','qstrings': { 'et': 'custom','ea': 'page view','product_id': window.location.pathname,'site': 'techcrunch' },}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");
		}
	</script>
	<script id='wp-parsely-api-js-extra'>
var wpParsely = {"apikey":"techcrunch.com"};
</script>
<script type="text/javascript" src="https://techcrunch.com/_static/??-eJx9y0EOAiEMQNELyXQICa6MZ8GhTkpKIbRo5vZOXLly/d+Hd3ckG8+MCkUhkxq8UHIbMHBHwZGsDTemGFVcKslS9AJ/tjP1xseTmH/51sRQDOp0nedOol+ZhiIfLiweHpM4AwmZS53O715vPsZ49SGsa/kAmbU98w==" ></script><script data-parsely-site="techcrunch.com" src='https://cdn.parsely.com/keys/techcrunch.com/p.js?ver=3.1.3' id="parsely-cfg"></script>
<script src='https://use.typekit.net/svv7knm.js?ver=20221031' id='tc-typekit-font-js'></script>
<script id='tc-typekit-font-js-after'>
try{Typekit.load({ async: true });}catch(e){}
</script>
<script id='tc-app-js-extra'>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</script>
<script type="text/javascript" src="https://techcrunch.com/wp-content/themes/techcrunch-2017/build/ec/js/main.js?m=1666625080g" ></script><script src='https://stats.wp.com/e-202244.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.4',blog:'136296444',post:'2433766',tz:'-7',srv:'techcrunch.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '136296444', '2433766' ]);
</script>
	<!-- Finished rendering TC markup -->
	</body>
</html>
