Google Hangouts Will No Longer Require A Plugin For Chrome Users

Next Story

Woot Founder’s Next Project Is A New Daily Deals Site Called ‘Meh.’

Has your distaste for one-off browser plugins kept you from using Google+’s group video chat service, Hangouts? That’s okay. I feel you. Plugins are the worst. What is this, 1999? Want me to install Shockwave, too? Hell, give me a couple sketchy browser toolbars while we’re at it. BONZAI BUDDIES FOR EVERYONE!!!

What was I talking about?

Oh, right. Hangouts.

Good news!

Starting sometime in the next few weeks, Google Hangouts will just work in Chrome. Other Hangout-compatible browsers (IE/Firefox/etc.) will still need the plugin — but Chrome will now have Hangouts support baked right in.

Between the transition to HTML5, new cross-browser protocols like webRTC, and even platforms like Unity trying to go plugin free, it’s going to be really, really hard to convince users to install plugins moving forward — so if your big idea requires one, you’ll want to find another way.

If you’re on Chrome Canary or another developer build of Chrome, the update is available now. Otherwise, the update should be coming your way in the next few weeks.