Droid (kinda) Does: Minimum requirements for Flash Player 10.1 exclude the original Droid

Next Story

Review: G-DRIVE Mini [UPDATE]

Android Police noticed today that the minimum requirements for Flash Player 10.1 actually exclude the original Motorola Droid, even though it was one of the devices Adobe showed off in their early Flash Player 10.1 demo videos.

What isn’t clear, however, is whether or not the minimum requirements will apply to the Droid from now on (meaning, Droid users no longer being able to download it), or if they’ve just made an exception to these requirements in the case of the Droid.

My gut tells me it’ll be the latter, but Android Police have reached out to Adobe for clarification, just be sure. We’ll let you know how it turns out.

The hefty minimum system requirements serve as a reminder that Flash probably doesn’t have a home on mobile phones, as much as we’d all love it to.

blog comments powered by Disqus