osx
snow leopard

Snow Leopard won't support PowerPC Macs

Next Story

‘Strong Bad’ Wii gameplay video, it’s coming to PC too

6846

Snow Leopard, or OS X 10.6, went out to developers at WWDC yesterday, and one glaring aspect that worries some is the fact that 10.6 is made specifically for Intel-based Macs, meaning that G5 won’t run it. In fact all PowerPC-based Macs are left out in the cold.

This was bound to happen, though, as Apple’s switch to Intel processors has been complete for many months now, but this makes it official. And realistically, would any G4 or G5-based machine run 10.6 well enough to even warrant the effort? I’ve got a dual-proc 2GHz G5 that barely runs 10.5, so I wouldn’t even try Snow Leopard, but some of you are gluttons for punishment.

blog comments powered by Disqus