Leopard To Exclude Legacy Apple Systems?

Next Story

Halo 3 Just Wants You To Believe

Your 800MHz G4 tower won’t be very useful this time next year. When you go to install Leopard on your system, you could be greeted with a nasty error message. Seems Apple has updated its minimum system requirements for Mac OS X Leopard to a 800MHz CPU or faster. That means if you’re still top-rocking a G4 PowerPC Mac, it’s time to get an upgrade. Not only will you get Leopard for free if you buy a Mac after the OS is released, but it’ll be so much faster for you in the long run.

The official requirements from Apple state that you must have “an Intel processor or a PowerPC G4 (800MHz or faster) or G5 processor” along with a DVD drive, built-in FireWire, 9GB of hard disk space (minimum) and at least 512MB of RAM. Apple’s decision to bump up system requirements is a valid one though, as Leopard was running too slow on 800MHz G4 systems to operate functionally.

Updated Leopard requirements to exclude 800MHz systems [AppleInsider]

blog comments powered by Disqus